Skip to main content

Scheduled Service Change: Upgrade Apache on WebLogin Servers

Event:
2020-05-10 08:00:00
Expected Duration:
2020-06-14 09:00:00
Status:
Closed
Brief Description:
Upgrade Apache on WebLogin servers
User Impact:
Users may not be able to login to websites running CUWebAuth versions older than 2.3.1.x after all WebLogin servers are upgraded.
Services Affected:
Authentication and Authorization
Subsites Affected:
CUWebLogin
Full Description:
From May 10 to June 14, Apache hosting (web2.login.cornell.edu) will be upgraded. This upgrade will not have an impact on visitors to websites with the correct version of CUWebAuth. In order to avoid an interruption of service, please update CUWebAuth in Apache prior to June 14, 2020. All IIS websites need to be converted to use Shibboleth authentication prior to June 14, 2020.

If you have issues or questions, please email idmgmt@cornell.edu

CIT TDX ID:
CRQ000001037953



Timeline of Changes

Description Current Status Date Time
From May 10 to June 14, Apache hosting (web2.login.cornell.edu) will be upgraded. This upgrade will not have an impact on visitors to websites with the correct version of CUWebAuth. In order to avoid an interruption of service, please update CUWebAuth in Apache prior to June 14, 2020. All IIS websites need to be converted to use Shibboleth authentication prior to June 14, 2020. If you have issues or questions, please email idmgmt@cornell.edu 2020-06-10 10:00:48
On May 10, Apache hosting (web2.login.cornell.edu) will be upgraded. This upgrade will not have an impact on visitors to websites with the correct version of CUWebAuth. Once the upgrade is complete, out of date versions of CUWebAuth will stop sending users to web2 but will instead be sent to web1, web3, and web4 login servers. On May 31 CIT will upgrade Apache on the remaining 3 WebLogin servers. Any implementation of CUWebAuth for Apache older than v.2.3.1.x will not be able to communicate with WebLogin servers after this upgrade. All CUWebAuth in IIS will stop working with WebLogin servers. In order to avoid an interruption of service, please update CUWebAuth in Apache prior to May 31, 2020. All IIS websites need to be converted to use Shibboleth authentication prior to May 31 2020. If you have issues or questions, please email idmgmt@cornell.edu 2020-04-30 10:49:00