Skip to main content

Security Alert: Update Zoom Client to Patch Security Issue

Date:
2020-04-03 09:53:00
Status:
Closed
Brief Description:
Zoom has issued a new version of its client applications for Windows and Mac to address security issues. All computers--both Cornell-owned and personally owned--running Zoom Client for Meetings should be updated.
Current Status:
All computers--both Cornell-owned and personally owned--running Zoom Client for Meetings should be updated.
Services Affected:
Web and Video Conferencing
Subsites Affected:
Web and Video Conferencing
Full Description:
Zoom has issued a new version of its client applications for Windows and Mac to address security issues. All computers--both Cornell-owned and personally owned--running Zoom Client for Meetings should be updated.

Windows and Mac users with administrative access for their computer should download a new version of the client from https://zoom.us/download .
Windows users with Cornell-managed computers who have access to Software Center can install the new client from there. Mac users with Cornell-managed computers who have access to Self Service can install the new client from there.

For more information about Zoom’s response to this issue and other topics, see https://blog.zoom.us/wordpress/2020/04/01/a-message-to-our-users/